1. #1
    Senior Member Follow User Gallery
    Join Date
    May 2007
    Location
    Raleigh NC
    Posts
    484

    Default Updating Scripts/Macros for new version.

    Do you have to change the [IConfig,X.X] code at the beginning of your scripts if you are migrating all the ones you created in a previous version to the updated Zbrush?

    Also, I have seen a couple scripts (not created by me) that have multiple [IConfig,X.X] at the beginning. Does this make it more compatible with other versions?

  2. #2
    Moderator Follow User Gallery
    Join Date
    Jun 2004
    Location
    UK
    Posts
    11,462

    Default

    I may be missing something but I've never found that the [IConfig] does anything. If you update your zscript/macro then certainly change it. Not doing so won't necessarily mean that code written for an earlier version of ZBrush will run correctly, and multiple [IConfig]s would simply execute one after another, the last run being the version set. But as I say, if there are (for example) interface items which have changed you'll still get an error. For most of my plugins I leave it out altogether.

  3. #3
    Senior Member Follow User Gallery
    Join Date
    May 2007
    Location
    Raleigh NC
    Posts
    484

    Default

    Great thank you. I was just curious if it did anything. That answered my question!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •