1. #1

    Default ZBrush on Mac - Multithreading Madness (Fan and temp going crazy)

    Hi
    I have just bought ZBrush for Mac and every time I start it up my CPU temperature shoots to 99 degrees and the fans stay on constantly. I have a late 2013 Macbook pro with an i7 processor and 16GB memory. I did a search on Google and this apparently is a known issue. People have suggested turning off Multithreading in the Performance sub-menu under 'Preferences' and although this does seem to work in that I no longer get the issues when I turn off the 'MultiDraw', 'Auto' and 'MultiThreaded IO', they turn themselves back on again when I restart ZBrush.

    I tried turning the options off and hitting 'Store Config' under the Config options but the only option that stays off is the 'MultiThreaded IO' option - I have to go and turn the other two off manually each time or my temperature and fan speeds shoot up.

    Now on reading the threads Pixologic says its an Apple issue and Apple says its a Pixologix issue but no-matter who's fault it is, surely Pixolocic can make the 'Store Config' option keep the other two multi-threading options stay off? It is so annoying having to turn these off each and every time I start ZBrush.

    I'm new to this application so maybe someone has found another way of altering these preferences to solve this???

    Thanks for any help on this.

  2. #2
    New Member Follow User Gallery
    Join Date
    Oct 2015
    Posts
    1

    Default

    Hi guys! I have the same problem, with macbook pro 2011, Zbrush 4r7, still hogging CPU, with simple mouse movement, some update or any advice guys?

  3. #3
    Senior Member Follow User Gallery
    Join Date
    Apr 2015
    Location
    Netherlands
    Posts
    349

    Unhappy

    Same problem here, mac CPU load and fan activity going mad, no matter what I do in ZBrush.

    This problem occurred all of a sudden. I suspect in my case this might have something to do with the recent macOS Mojave upgrade. As mentioned before, lowering the amount of ZBrush CPU threads in ZBrush helps, but isn't stored along with the Preferences.
    visualization • illustration • 3D design — metinseven.nl

  4. #4
    Super Moderator Follow User Gallery
    Join Date
    May 2001
    Posts
    21,530

    Questions about using ZBrush? Check out these valuable resources:

    ZBrush Tutorial Movies: Link
    Download Center: (PDF documentation, models, plugins): Link

    Online Documentation: Link

    ZBC FAQ: http://www.zbrushcentral.com/faq.php
    ZBC Advanced Search:
    http://www.zbrushcentral.com/search....st&forumchoice

  5. #5
    Senior Member Follow User Gallery
    Join Date
    Apr 2015
    Location
    Netherlands
    Posts
    349

    Thumbs up

    Thank you Aurick. I'll use this workaround, although the inactive state of the MultiDraw button is not stored when saving the preferences, so until it's fixed I'll have to deactivate it by hand at the start of each ZBrush session.
    visualization • illustration • 3D design — metinseven.nl

  6. #6
    Senior Member Follow User Gallery
    Join Date
    Apr 2015
    Location
    Netherlands
    Posts
    349

    Thumbs up

    Hmm, I just discovered here that there's been a minor update of 2018.1 since I installed it. I installed the latest version of 2018.1, did a few tests, and it seems that the excessive CPU usage and resulting fan activity is fixed in that update.
    visualization • illustration • 3D design — metinseven.nl

  7. #7

    Default

    Thanks for pointing that out. Works a lot better, may save me from buying a pc. I still have to turn off Multidraw to avoid running too much fan.

  8. #8
    Senior Member Follow User Gallery
    Join Date
    Apr 2015
    Location
    Netherlands
    Posts
    349

    Default

    When I turn off MultiDraw, ZBrush starts to slow down considerably, but installing the recent 2018.1 update seems to have fixed the CPU heat / blowing fan issue. *fingers crossed*
    visualization • illustration • 3D design — metinseven.nl

  9. #9

    Default

    I've got an older Retina Macbook pro. I didn't notice the slowdown with multidraw off (thought that was just for rendering). With it off the fans stopped running, with Multidraw on the fans were still chugging, but the computer was not getting as hot as before the patch.

  10. #10
    Senior Member Follow User Gallery
    Join Date
    Apr 2015
    Location
    Netherlands
    Posts
    349

    Default

    I also read that deactivating Multidraw should only be noticeable during BPR rendering, but when I turned it off I immediately noticed a slowdown in navigating around my model, etc.. But so far so good since the latest update, which also removed a few old settings in the Performance section of the Preferences.
    visualization • illustration • 3D design — metinseven.nl

  11. #11
    Senior Member Follow User Gallery
    Join Date
    Apr 2015
    Location
    Netherlands
    Posts
    349

    Unhappy

    Darn, just started working with ZBrush again, and the CPU temperature and fan activity go berserk again. I've now turned the MaxThreads to 8 in stead of 16, but I assume that has the disadvantage of using approximately half of my Mac's processing power for ZBrush. And the MaxThread setting isn't stored along with the Preferences, so it needs to be set at the start of each ZBrush session.

    I really hope this issue will be fixed soon.
    visualization • illustration • 3D design — metinseven.nl

  12. #12
    New Member Follow User Gallery
    Join Date
    Oct 2018
    Posts
    3

    Default

    I can confirm the same, even running on 18 cores - 100% CPU usage, making higher geometry counts impossible to work with - I've sent a tweet out to their new twitter account, hopefully they'll have a fix soon:

    https://twitter.com/furbystudios/sta...82759298174976

  13. #13
    Super Moderator Follow User Gallery
    Join Date
    May 2001
    Posts
    21,530

    Default

    This has been issue for a few versions now and a solution has proven elusive. It's something that the development team continues to work on and seek a solution for but we have absolutely no ETA regarding when that might actually come to fruition.

    For now, the Knowledgebase article linked above has the only known workaround.

    Questions about using ZBrush? Check out these valuable resources:

    ZBrush Tutorial Movies: Link
    Download Center: (PDF documentation, models, plugins): Link

    Online Documentation: Link

    ZBC FAQ: http://www.zbrushcentral.com/faq.php
    ZBC Advanced Search:
    http://www.zbrushcentral.com/search....st&forumchoice

  14. #14
    Member Follow User Gallery
    Join Date
    Aug 2008
    Location
    Montreal
    Age
    40
    Posts
    97

    Default

    Would you mind elaborating what is the cause of this?

    I am about to purchase an imac pro (or wait for 2019 mac pro)

    Would like to know if zBrush is usable on a heavy multithread machine.


    Is it something that can only be fixed on apple’s side?

  15. #15
    Senior Member Follow User Gallery
    Join Date
    Apr 2015
    Location
    Netherlands
    Posts
    349

    Default

    I'm a ZBrush user, not a developer, but the last few sessions the problem did not recur. I've got an iMac Pro.

    If it recurs, I've added the MaxThread setting to my custom UI, and turn it back to 6 or 4 threads in case the CPU goes wild again. ZBrush is still quite fast with a lowered amount of threads.

    Looking at the occurrences, the issue seems to come up pretty randomly, or only in specific cases, maybe when intensively using Sculptris Pro on a dense mesh?

    I did notice more fan activity lately, also in other software, so it wouldn't surprise me if it's an Apple macOS problem.
    visualization • illustration • 3D design — metinseven.nl

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •