1. #46
    Senior Member Follow User Gallery
    Join Date
    Mar 2009
    Location
    within US borders
    Posts
    551

    Default

    No worries Drazzer! Let me see if I can help you out.

    If you're not using Playonlinux (or alternative) I would recommend that instead of just installing straight to a default Wine prefix. It's some advanced and fumbly territory if you're not very experienced yet and Playonlinux does a great job of keeping things simple.

    I've got my installation for Zbrush 2018 set using Wine 3.5 64-bit (but I wouldn't imagine 3.6 to be a problem). In the Wine Config, it's set to Windows 7, which hasn't given me any troubles. I'll post a screen of my config below:



    A page that has helped me with this can be found here

    Hopefully these hints get you going without those nasty black lines!
    "Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius — and a lot of courage to move in the opposite direction." -E.F. Schumacher


  2. #47

    Default Still No go Zbrush 2018, Linux Mint 18.3

    Well, I tried using PlayonLinux using Wine 3.5 with windows 7 but it still comes up exactly the same. I just installed Linux so is there anything else I need to install for this to work. Here is a screenshot.

    as you can see when i try to add anything to the canvas I can only see lines of it. Also one of my files, msvcr90, didn't have an asterisk next to it like in the other screenshot. Thanks for any advice.

    Update: Nevermind, I actually got it to work finally. I tried reinstalling all the components to make sure I didn't miss one and it worked. I don't remember installing vcrun2008 the first time. But thanks for all the help. Hope they come out with an official Linux version still. In the meantime happy Zbrushing everyone.

  3. #48
    Senior Member Follow User Gallery
    Join Date
    Mar 2009
    Location
    within US borders
    Posts
    551

    Default

    Awesome that you found that. Before seeing the note, I was wondering if some component had been overlooked somewhere.

    Take care!
    "Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius — and a lot of courage to move in the opposite direction." -E.F. Schumacher


  4. #49

    Default Things have MASSIVELY improved

    Zbrush hidpi support is still lacking, they have some TEENY icons here and there and they really need to fix it. I will just make a dedicated zbrush user, and have my laptop start in a lower res when that user logs on, and move my zbrush install to that user.


    That said, using wine 3.17, startup performance is better and you need to tweak and install fewer things.

    Installed wine 3.17

    Installed winetricks

    winetricks vcrun2010 vcrun2008 corefonts win10

    Then I used wine to run the installer. And then use wine to run zbrush. It all seems to run great so far, though there might be another lib or so needed for zremesher. The basics work though.

    Fast boot, fast sculpting, fast speed. WEEE!

  5. #50

    Default

    Also, you can disable 'emulate a desktop' in wine, as zbrush startup is now just fine on wine.

  6. #51
    New Member Follow User Gallery
    Join Date
    Oct 2018
    Posts
    2

    Default

    Tried wine under CentOS7 but some quick tests failed.

    However, qemu with -kvm will run Windows Server 2012 or another version of Windows. A wacom tablet can be passed through also (used a somewhat older version that installs without the device). Got it fully functional running 15M polys without lag.

    A secondary mouse can be useful when the tablet is passed through when needing to quickly do something in the host.

  7. #52

    Default

    +1 for Linux version. For my needs it works better as an OS (tablet just works, no issues with forced updates).

    In a meantime I've managed to get the demo running - I'm testing the waters before I'll try to mess with a PC in my workshop.
    Has anyone noticed a bit of tearing (or something closer to frame being one step behind) on Nvidia card? Not sure the problem shows on Radeons / Intel as well (don't have Radeon card at home to test). It's minot but noticeable on my end (and I'm a bit picky on this matter as I've experienced similar thing in MoI which prevented for me its use on Linux - but it's worse there).

    Initially the maximize / minimize button in the UI didn't maximize to full screen , but after tweaking window decoration settings it started to work.

    Other than that - performance in initial test is super. Everything extremely smooth and enjoyable , Dynamesh / Zremesher / Sculptris Pro work out of the box.

  8. #53

    Default

    Here anybody tried to run Zbrush in linux via docker ??

    Nowadays most of the apps are cross platform, plus microsoft also participating in linux foundation. No idea why software company like Adobe, Pixologic are stuck in windows ****.

    Most of the VFX studio having pipeline on top of linux, Some of them are using Zbrush on separate windows box under compulsion and some are using Mudbox because it's easy to integrate in linux pipeline.

  9. #54

    Default

    @ ruchitbhatt : out of curiosity - why would you like to run it through Docker? I guess it is doable, but setting up graphics through Docker was a pain last time I've checked and you'll still need translation layer like WINE. So essentially you would run WINE inside Docker.
    For most use cases , if you need some sort of sandboxing, I think something like Zbrush/Wine combo packaged as Flatpak would make more sense IMO.

  10. #55

    Default ryzen 1290x 12cores

    Hello.
    The z run really fine. But my times in zremesh for example is lower to 20% with respect to windows times.
    How do I solve it?
    Apparently the cores are charging 15% of their potential!
    Thanks
    My sistem is ryzen 1920x nvidia 1060 and 32gb ram, run ubuntu 18.04.2
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Captura de pantalla de 2019-03-21 09-59-20.png 
Views:	10 
Size:	707.2 KB 
ID:	631779  

  11. #56

    Default

    atm I'm in the middle of documenting of all the little issues encountered while using ZB under WINE.
    For the most part it works fine as many have mentioned, but for example decimation often gets stuck during pre-process (it says it is calculating, but in reality you don't see any load on the cores), sometimes you can't delete subtool (it starts working after app restart), sometimes FBX export fails.
    Would be awesome to see fixes for those as we would get a super smooth experience without Pixologic committing to working on native build (which would be even more awesome, but I fear less likely).

  12. #57

    Default

    If I turn off 8 of the 12 cores that the CPU has, the performance supposedly used is 50%.
    This is very strange.

Page 4 of 4 FirstFirst 1234

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •