1. #1

    Default Curves Total Failure

    This script attempts to merely create a new curve list and add a single two point curve, but ZBrush says it's a bad variable? What variable? I'm not using a variable.

    [if, 1 = 1,
    [IPress,Tool:PolyMesh3D] //Kludge to start with clean slate.
    [CanvasStroke,(ZObjStrokeV02n48=H2BDV1D5H2BDV1D7H2B DV1DEH2BDV1DFH2BDV1E0H2BDV1E1H2BDV1E2H2BDV1E3H2BCV 1E4H2BCV1E6H2BCV1E8H2BCV1E9H2BCV1EAH2BCV1EBH2BCV1E CH2BCV1EDH2BCV1EEH2BCV1EFH2BCV1F0H2BCV1F1H2BCV1F2H 2BCV1F3H2BCV1F4H2BCV1F6H2BCV1F7H2BCV1F8H2BCV1F9H2B CV1FAH2BCV1FBH2BCV1FCH2BCV1FDH2BCV1FEH2BCV200H2BCV 201H2BCV202H2BCV203H2BCV204H2BCV205H2BCV206H2BCV20 7H2BCV208H2BCV209H2BCV20AH2BBV20BH2BBV20CH2BBV20DH 2BAV20DH2BAV20D)]
    [IPress,Transform: Edit]
    [CurvesNew, myCurves] //Make a curve list
    [CurvesNewCurve] //New curve
    [CurveAddPoint, 0,1.0,1.0,0.3333]
    [CurveAddPoint, 0,1.0,1.0,1.0]
    ]


    The reference seems clear that this is the proper command format, but it's causing an error:


    If I take the offending line out, I see some action in adding a new curve, while in the CurveMultiTube brush, but a long series of new curve commands only results in a single new stuffy little curve every time I run the script.

    [if, 1 = 1,
    [IPress,Tool:PolyMesh3D] //Kludge to start with clean slate.
    [CanvasStroke,(ZObjStrokeV02n48=H2BDV1D5H2BDV1D7H2B DV1DEH2BDV1DFH2BDV1E0H2BDV1E1H2BDV1E2H2BDV1E3H2BCV 1E4H2BCV1E6H2BCV1E8H2BCV1E9H2BCV1EAH2BCV1EBH2BCV1E CH2BCV1EDH2BCV1EEH2BCV1EFH2BCV1F0H2BCV1F1H2BCV1F2H 2BCV1F3H2BCV1F4H2BCV1F6H2BCV1F7H2BCV1F8H2BCV1F9H2B CV1FAH2BCV1FBH2BCV1FCH2BCV1FDH2BCV1FEH2BCV200H2BCV 201H2BCV202H2BCV203H2BCV204H2BCV205H2BCV206H2BCV20 7H2BCV208H2BCV209H2BCV20AH2BBV20BH2BBV20CH2BBV20DH 2BAV20DH2BAV20D)]
    [IPress,Transform: Edit]
    //[CurvesNew, myCurves] //Make a curve list


    [CurvesNewCurve] //New curve
    [CurveAddPoint, 0, -1.0, -1.0, -1.0]
    [CurveAddPoint, 0, -1.0, -0.3333, -1.0]


    [CurvesNewCurve] //New curve
    [CurveAddPoint, 1, -1.0, 1.0, -1.0]
    [CurveAddPoint, 1, -0.3333, 1.0, -1.0]


    [CurvesNewCurve] //New curve
    [CurveAddPoint, 2, -1.0, 1.0, -1.0]
    [CurveAddPoint, 2, -1.0, 0.3333, -1.0]


    [CurvesNewCurve] //New curve
    [CurveAddPoint, 3, 0.3333, 1.0, -1.0]
    [CurveAddPoint, 3, 1.0, 1.0, -1.0]


    [CurvesNewCurve] //New curve
    [CurveAddPoint, 4, -1.0, -1.0, 1.0]
    [CurveAddPoint, 4, -1.0, -0.3333, 1.0]


    [CurvesNewCurve] //New curve
    [CurveAddPoint, 5, 1.0, 1.0, 1.0]
    [CurveAddPoint, 5, 0.3333, 1.0, 1.0]
    ...and so on

  2. #2

    Default

    OK, if I leave the offending curve list statement out and then use CurvesToUI, I get my curves into ZBrush after all:

    But I then don't know how to close the current curves list since I don't know its name, and perhaps since there already is a curves list, that's why I can't make a new one to start with?

    CurveMeshes fails though, badly, with 0.05 radius:

    Those walls just get thinner if I switch to 0.0005, and bulk up into a full box and beyond at 0.1 or 1:

    Ah, these aren't even supposed to be curve tubes at all, but a mesh from wires!

    I don't even want that. Not sure why it can't make it from these single lines though. The tip is that thickness 0 means a flat mesh. I had assumed this was a tube mesh system. With thickness 0 I get the same thing with no wall thickness.

  3. #3

    Default

    However, if after invoking the UI command to see the wires and then I switch to CurvesMultiTubes and drag out a new curve, the existing curves, some of them, become pointy tubes:

    If I forego the silly mesh command and reload, and click on one of the lines with the CurvesMultiTube brush I get something interesting:

    However, vertical beams are bad, when I click on those:

    Meanwhile the InsertCylinerExtr brush converts most of it to various garbage:

    And that changes the behavior of the CurvesMultilTubes brush the next time I use it to click on a wire:

    This is all just bad, buggy, behavior.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •