1. #16
    Senior Member Follow User Gallery
    Join Date
    May 2006
    Location
    Haarlem, Netherlands
    Age
    71
    Posts
    121

    Default

    Hi Marcus,

    As you suggested, I put the following code into the LayerPaint-plugin:

    [varset,bestand,[FileNameMake,Paint#.txt,PaintNum]]
    [memcreatefromfile,el_membestand[strmerge,"ZBRUSH_ZStartup\ZPlugs\LayerPaintTemp\ ",bestand],123]//Paint#",PaintNum,".txt"],123]
    [memwritestring,el_membestand,"[if,1,",0,1]
    [memsavetofile,el_membestand,[strmerge,"ZBRUSH_ZStartup\ZPlugs\LayerPaintTemp\ ",bestand],1]//Paint#",PaintNum,".txt"],1]
    [memdelete,el_membestand]
    [ipress,[strmerge,"tool:Paint#",PaintNum]]
    [FileNameSetNext,[strmerge,"ZBRUSH_ZStartup\ZPlugs\LayerPaintTemp\ ",bestand]]//Paint#",PaintNum,".txt"]]
    [ipress,zscript:load]

    Now, for some reason zb does NOT accept this code: arriving at 'If,1,' zb refuses the code.

    Maybe you have some idea what's going wrong?

    BTW. You said a week ago that you were thinking about an alternative route for what I'm trying to do in this plugin. You were not sure yet wheter it would do the trick. I'm curious about your follow up.

    Greetings, EddyL

  2. #17
    Moderator Follow User Gallery
    Join Date
    Jun 2004
    Location
    UK
    Posts
    11,462

    Default

    Eddy,

    Can you clarify the problem? Have you looked at the recorded zscript to see that it has been edited correctly? And will it play correctly if you load it using the ZScript:Load button?

  3. #18
    Senior Member Follow User Gallery
    Join Date
    May 2006
    Location
    Haarlem, Netherlands
    Age
    71
    Posts
    121

    Default

    Hi Marcus,

    The load file only states: [If, 1,

    So, what happened with the CanvasStrokes-information?

    Greetings, EddyL

  4. #19
    Moderator Follow User Gallery
    Join Date
    Jun 2004
    Location
    UK
    Posts
    11,462

    Default

    Eddy,

    I can't tell what is going wrong from code snippets. Is your zscript recording saving properly to the file name you specify? Comment out some of your code to track down the error if you can.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •